Support

GK Amplification 2 Pro

Release notes:

  • Compatible with MacOS 10.13 and 10.14
  • Minimal required MacOS version changed to 10.9 (Mavericks)
  • AAX plugin stability improved

Supported OS:

Mac OS X 10.9 - macOS 11

Supported platforms:

AAX 32b, AAX 64b, AU 32b, AU 64b, Standalone app, VST2 32b, VST2 64b, VST3 32b, VST3 64b, Apple Silicon Compatible
If you have a moment, please, let us know how you plan to use our software