Support

U78 Saturator

The U78 Saturator is iLok protected. Please make sure you have the latest version of the iLok License Manager installed and that you have an iLok account. This is necessary for both trial and full versions.

For the trial version, you do not need any serial number. Please refer to this activation guide.

Release notes:

  • macOS 12 and newest DAWs compatibility improved. 32bit builds are no longer included for macOS platform so older 32bit DAWs are now not supported.
  • Minimal required macOS version changed to 10.11 (El Capitan). 
  • Compatibility with host presets and stored plugin state made with version 1.0.0 is not guaranteed.

Supported OS:

Mac OS X 10.11 - macOS 12

Supported platforms:

AAX 64b, AU 64b, VST2 64b, VST3 64b, Apple Silicon Compatible
* We will send you temporary link to download your product there.
If you have a moment, please, let us know how you plan to use our software